更新,VirtualBox 4.2.1 for OS X 已经放出,专门解决了这个BUG啦!

昨天升级OS X到10.8.2后VirtualBox无法运行了,只要一运行就弹出“VT-x is being used by another hypervisor。。。”的错误信息。在网上找了好久,发现跟我遇到相同问题的人大把,但只有Ivy Bridge的机子有问题。目前只能等待VirtualBox更新了,我本以为这是一个严重的BUG,认为今天Oracle就会发布更新,可我错了,连一个DEV版都没有找到。但很多人像我一样在虚拟机里运行window或者其他系统是为了工作的,因此只能临时性解决了:
1.转到Fusion .先用VitualBox将目前的虚拟电脑导出成 .ova格式,再在Fusion里导入。

2.转到Parallels .安装后按向导将VirtualBox里的虚拟电脑自动转换过去即可。

以上两种办法都可以试用一段时间,希望这断时间内VirtualBox发布更新版解决此BUG。

如果想跟进相关消息可以查看以下帖子:

1.https://discussions.apple.com/message/19623146#19623146

2.https://discussions.apple.com/thread/4314420?start=0&tstart=0

3.https://forums.virtualbox.org/viewtopic.php?f=8&t=51331

4.https://www.virtualbox.org/ticket/10965#comment:11

5.https://discussions.apple.com/thread/4314420?start=0&tstart=0

6.http://news.ycombinator.com/item?id=4546808